テクノモンキーのアプリ開発日記

テクノモンキーの開発ブログです。iOS、Android、Unity、Cocos2d-xなどアプリ開発関連のTipsやアプリ開発に役立つ情報を発信します。

【Android】This Gradle plugin requires a newer IDE able to request IDE model level 3. For Android Studio this means version 3.0+

https://cdn-ak.f.st-hatena.com/images/fotolife/h/hmbdyh/20170110/20170110101721.jpg

仕事で、既存のプロジェクトをAndroid Studioにインポートしてでビルドしようとしたら発生したエラー。



This Gradle plugin requires a newer IDE able to request IDE model level 3.

Error:This Gradle plugin requires a newer IDE able to request IDE model level 3. For Android Studio this means version 3.0+

Gradleのプラグインが、新しいAndroid Studioバージョンを要求しているエラーだと思われます。
(上記の場合はAndroid Studioの3.0以上。)


とりあえず、Android Studioのアップデートを行ったら消えました。

ちなみにGradleのバージョンアップの方法は以下が参考になります。

qiita.com



Android StudioのGradleって厄介ですね。

時間がある時にちゃんと理解した方が良さそう。